PDA

View Full Version : // psp firmware //


born invincible
07-23-2006, 12:29 AM
this question is for anyone who has a older PSP... i kept hearin about how the game makers when they put out a new game... u will have to get the latest firmwares on your PSP to play the game... then it hit me like a month ago when i bought a new game.. good thing i was at v2.0.. and i could update to v2.6.. allowing me to play the game, and still run my homebrew

i guess my question is.. has this happened to anyone lately when buying a new game. theres a few games that are gonna drop soon and i want them.. but im affraid to buy cause of the firmware crap!!!!!!!

Icurus
07-23-2006, 12:54 AM
Do whatever you want. Truth be told, eventually you'll be able to do any homebrew. But you should also read up on new homebrews, so you can decide whether to upgrade to the next firmware. I barely use my psp, but I will always update cause one day they will be up to a number where you wont be able to upgrade to, and that firmware may have really good features but because you waited so long, you wont be able to upgrade that high. Wait and see what happens, give it a year.

born invincible
07-23-2006, 02:21 AM
Do whatever you want. Truth be told, eventually you'll be able to do any homebrew. But you should also read up on new homebrews, so you can decide whether to upgrade to the next firmware. I barely use my psp, but I will always update cause one day they will be up to a number where you wont be able to upgrade to, and that firmware may have really good features but because you waited so long, you wont be able to upgrade that high. Wait and see what happens, give it a year.



i doubt Sony will ever make a firmware worth it... compared to homebrew out there.




anyways... anyone encountered the problem i mentioned above?

Bloo
07-24-2006, 03:26 PM
Yeah, I have. GTA:LCS

I had a 1.5 firmware PSP and when I read that they were extremey rare I was happy I was able to grab one. I used it for all kinds of things, chess, calculator, web browser (before the one Sony made), remote. But I wanted to play GTA and it required you update to version 2.0. I was hoping that the rumors I heard that it wasn't nessacairy were true but alas :(

I'm kinda in the same situation again as Sony is planning big things for the PSP. My main interest is the PSOne game downloads that will be possible by years end. But you can pretty much guarentee that Sony will require you to update your PSP to the latest firmware before you can exploit that feature. Plus with Sony now making game demos available for PSP owners there's a bit more incentive to upgrade.

I gave in to the inevitable and now am running firmware 2.71 on my once 1.5 PSP. Do I miss the homebrew? Somewhat, (primarily the NES/SNES and Genesis emulators) but honestly the PSP could barely pull of the SNES and Genesis without some slowdown in most games so it wasn't all that enjoyable anyway. All in all I think the PSOne emulator will be more than enough for me to feel I've gotten my money's worth, hackable firmware or not.

Icurus
07-24-2006, 03:47 PM
There is a program now for 1.5 firmware that runs like a 2.7. So, its like running homebrews and iso, plus playing any umd games you want.

Ill find it, cause my friend has the program but you said you already upgraded to a 2.7 anyway.

born invincible
07-26-2006, 12:26 AM
There is a program now for 1.5 firmware that runs like a 2.7. So, its like running homebrews and iso, plus playing any umd games you want.

Ill find it, cause my friend has the program but you said you already upgraded to a 2.7 anyway.


i read about that somewhere too... cant remember where tho.


i believe with the new modchip thats out it will solve the firmware/homebrew issue.


im still running v2.6 i bought MLB06 the Show a few months back. when i tried to play the game it told me i hadda bump up to atleast v2.6. i was at v2.0 at the time.. since the GTA exploit can still be used with v2.6 i went ahead and updated... so i keep runnin my homebrew and play my PSP games..

my main concern is the newer games that will be droppin in the future... particularly MGS portable ops. i want that game ... bad. but im affraid sony might try to pull the okie doke on me and make me upgrade before i can play......